Posted Wed, 09 Jan 2019 23:02:03 GMT by
Hi, Since a couple of days, me and two colleagues, can't save edited BIML files anymore. Visual Studio opens the BIML file, we can edit them, but trying to save them doesn't do anything (Visual Studio also doesn't notice the changes, it does not shows a * behind the file while editing). I've already upgraded BIML express to the latest version, but that gives the same result. Visual Studio is version 15.9.4. BIMLExpress is 5.0.63501.0. Hope you can help, Walter.
Posted Sat, 11 May 2019 03:46:18 GMT by
Here still the same problem. Solution worked for some people here for a couple of days (and after that it started again), and with no result for others... Please help... :(
Posted Sat, 11 May 2019 03:46:21 GMT by jacob alley
Can any of you guys who are still experiencing this issue please email and reference this post and we will get you an instrumented build to help us track down the problem.
Posted Sat, 11 May 2019 03:46:23 GMT by
I've had this issue and for me, the trick that fixed it was to make sure to install using "Run As Administrator". Hope this helps! David
Posted Mon, 13 May 2019 10:08:01 GMT by

It's working fine now, i did a reinstall of the software and did not install any visual studio updates after that.

Posted Sun, 01 Sep 2019 20:13:18 GMT by jacob alley
Can you try and uninstall BimlExpress completely and see if you have any luck? In order to uninstall, on the Visual Studio tool bar, click Tools → Extensions and Updates and then find BimlExpress and click 'uninstall'. If that does not work we need to delete the registry keys and try again. First uninstall BimlExpress like before. Next, open 'regedit' (or your favorite registry editing tool). You can find 'regedit' by simply searching from the search bar on the taskbar, but it is also located at C:\Windows on most machines. Go to HKEYCURRENTUSEER →SOFTWARE →Varigence →BimlExpress →5.0 and delete the contents of that folder. Now reinstall BimlExpress. Note you will have to reenter your key because we deleted the registry keys. Please let us know if you are still having issues after this.
Posted Wed, 16 Oct 2019 17:48:37 GMT by

Both of our primary BIML developers are experiencing this issue with VS2017 after an update to VS2017. I have also tried the recommended trouble shooting steps listed above including the complete uninstall with Registry key reset and there was no change in behavior. I also completely re-installed Visual Studio and that also didn't change the result. Current work around is to make and save changes in a different text editor, such as Notepad++. Would really prefer to be able to use BIML Express as intended.

Posted Thu, 17 Oct 2019 02:10:43 GMT by

Have you tried to use the latest version of BimlExpress? Try following the above steps to completely uninstall, and then when installing use "Run as Administrator" on the installer.

Posted Fri, 01 Nov 2019 21:09:10 GMT by
I am having the same issue, I can edit the files, but also I can not save them. Also preview is not showing up. I tried the above steps, but that does not work. Visual Studio 2017 15.9.5, BimlExpress 5.0 (32-bit) Build 5.0.63501.0 Features and Bundles: No features or bundles have been authorized Plugins: No plugins have been loaded Kind regards, Vincent
Posted Mon, 21 Sep 2020 14:12:17 GMT by

Same problem in VS2019

You must be signed in to post in this forum.